Back to overview
Downtime
Network Issues
Mar 22 at 09:24pm CET
Resolved
Mar 22 at 10:54pm CET
Resolved
Affected services
Updated
Mar 22 at 10:30pm CET
It looks like our servers have a network connection again.
Affected services
Updated
Mar 22 at 09:36pm CET
We have identified the issue and are working with our partners on a fix
Affected services
Created
Mar 22 at 09:24pm CET
We are currently experiencing network issues. We have contracted our partners and are investigating this issue!
Affected services